Updating User properties using GraphAPI

Newly created user is not showing up in the Global Address List or Offline Address Book

Issue: The Newly created user does not show up in the GAL or OAB.

Reason: This issue occurs when the "showInAddressBook" attribute is not populated on user Object.

Requirement: ActiveDirectory Powershell Module or Active Directory Administrative Center.

Solutions: Populate the showInAddressBook attribute

Fix using the Active Directory Powershell Module

You can verify if the "showInAddressBook" attribute is populated using the following CMD.

Get-ADUser newuser -Properties * | fl showInAddressBook

You will see a value like below if the attribute is populated.

CN=Default Global Address List,CN=All Global Address Lists,CN=Address Lists Container,CN=Domain,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=corp,DC=domain,DC=com

If the result does not return anything, then the attribute is required to be populated.

Copy the attributes from the existing user who is showing in the GAL.

$AddressListDN=(Get-ADUser sunil -Properties *).showInAddressBook

Run the below CMD to set the attribute for the New User.

Set-ADUser Newuser -Add @{showInAddressBook=$AddressListDN}

Fix using the Active Directory Administrative Center

 Open Active Directory Administrative Center and search for a user who is showing in the GAL to copy the attributes from the "showInAddressBook"
Go to "Extensions" >> "Attribute Editor" look for the "showInAddressBook" attribute and copy the value.


To copy the value select the entry and click on the Remove then select all and copy and click on Cancel.


Now repeat the same steps with the problematic user and copy the value in "ShowInAddressBook", attribute, if you are not able to find the attribute "ShowInAddressBook" click on Filter and make sure you have not selected the "Show only attributes that have values" 


UnCheck the "Show only attributes that have values" and again look for the "ShowInAddressBook" and populate the attribute with the copied values.

Once the attribute is populated wait for few hours and the user should be showing up in the GAL.

This completes my post on how we can fix a new user issue not showing up in the GAL, we covered how the same can be fixed using the PowerShell or using the Active Directory Administrative Center.

Comments